Concatenar fechas en Excel.

En este tutorial explicamos cómo Concatenar fechas en Excel, asegurando que sea el formato de fecha correcto y no el número de Excel que representa las fechas.

Concatenar fechas en Excel

Visita nuestra página de Facebook, para que no te pierdas nuestros de más Tutoriales y Tips.

 

Resumen rápido Excel concatenar fechas.

En este resumen rápido te decimos las fórmulas para unir fechas en Excel. Más adelante realizamos un ejemplo para aclarar las dudas que puedan surgir.

¿Cómo concatenar fechas en Excel?

El problema al concatenar fechas es que no aparece el formato deseado, asi que solo debemos asegurar el formato y después concatenar, esto se hace de la siguiente forma:

Para esto necesitamos usar 2 funciones: Concatenar y Texto.

  • La fórmula Concatenar nos ayuda a unir los textos de las fechas.
  • La función Texto nos ayudará a mantener el formato.

Si tenemos una fecha en la celda A3. Primero usaremos la función Texto para mantener el formato en la celda B7, luego usaremos concatenar para unir la fecha con un texto.

En la celda B7:

=TEXTO(A3; “dd/mm/aa”)

Luego la función concatenar para fechas.

=CONCATENAR(“La fecha es: “; B7)

Ya tendremos la fecha correctamente: La fecha es: 26/05/22

Ve un tutorial de la formula Texto aquí.

 

Ejemplo.

En el siguiente ejemplo vamos a Concatenar fechas en Excel manteniendo el formato de la fecha y la hora.

En la imagen anterior vemos que tenemos una fecha y una hora.

  • Celda A3, contiene una fecha.
  • La Celda B3, contiene una hora.

En el primer ejemplo de la imagen.

En el primer ejemplo vemos que la función concatenar por sí sola no muestra la fecha con el formato adecuado:

= CONCATENAR(“La fecha es: “; A3)

EL resultado es:

“La fecha es: 44707”.

El cual es correcto para Excel, pero para nosotros no nos dice nada sobre la fecha, porque no tiene un formato adecuado.

Segundo caso.

En el segundo ejemplo usamos la formula Texto para mantener el formato, en la celda B7.

= TEXTO( A3; “dd/mm/aa”)

Ahora notamos que el resultado de la fecha ya tiene el formato correcto.

Tercer ejemplo, concatenar fechas en Excel.

Por ultimo usaremos la función Concatenar para unir el texto y la fecha en el formato correcto.

= CONCATENAR( “La fecha es: “; B7)

Ahora el resultado es concatenar la fecha con el formato adecuado:

La fecha es: 26/05/22

Podríamos haber usado todo en una sola celda, algo así:

= CONCATENAR( “La fecha es: “;  TEXTO( A3; “dd/mm/aa”)

 

También escribimos un ejemplo con la hora. Así se podrá concatenar la fecha y hora en Excel con el formato adecuado.

Este proceso lo podemos aplicar para darle un formato específico a los textos, fechas, horas, etc. que vamos a unir.

Para más tutoriales de Excel ve a este enlace.

Algunos temas que pueden interesarte:

Función INDIRECTO Excel (INDIRECT en inglés).

Fijar una celda en una fórmula de Excel.