Función Texto Excel (Text en Inglés)

En este tutorial se explica la función Texto en Excel. Esta función nos ayuda a dar formato a textos. Ya sea pasar de Texto a fecha, porcentaje, etc. Se utiliza cuando tenemos alguna fórmula y el resultado lo necesitamos en un formato en específico.

Esta función se usa principalmente al momento de Concatenar elementos, ya que al unir Textos de varias celdas a una sola se pierde el formato, y con la fórmula Texto se lo damos.

Función Texto Excel

Por ejemplo, una fecha al concatenarla, ya no tiene el formato, sino el número con que Excel identifica las fechas.

Visita nuestra página de Facebook, para que no te pierdas nuestros de más Tutoriales y Tips.

Resumen rápido Excel Formula Texto.

En este resumen rápido explicamos los parámetros de la función Texto en Excel. Más adelante dejamos algunos ejemplos, para resolver las dudas que puedan surgir.

Función Texto (Text en inglés), en Excel.

La fórmula Texto o Text en inglés tiene los siguientes parámetros.

= TEXTO( Contenido; Formato)

Dónde:

  • Contenido, es el contenido de la celda pueden ser letras, números, alguna fecha, porcentaje, etc.
  • Formato, es el formato que le daremos el contenido.

Estos son algunos ejemplos de formatos:

Fechas:

  • “dd/mm/aa”, en ingles “dd/mm/yy”
  • “Dd-mmm-aa”, en inglés “dd-mmm-yy”
  • “dd-mmm”

Horas:

  • “h:mm”
  • “h:mm:ss”
  • “h:mm:ss AM/PM”

Porcentaje:

  • “0%”
  • “0.0%”

Separación de miles:

  • “#,###”
  • “#,#”

 

Ejemplo de la fórmula Texto.

Ya vimos que es la función Texto en Excel, ahora veamos algunos ejemplos.

El formato se lo podemos dar directamente a la celda. Pero cuando usamos formulas, sobre todo para unir textos (como Concatenar), el formato del Texto se pierde y ahí es donde entra la fórmula Texto.

Tabla de ejemplo.

En la siguiente imagen mostramos algunos ejemplos, primero mostramos la Función que se usa para el Resultado, luego el contenido que tendrá la función y al final el resultado.

Vemos en la fila Dos, que el contenido es el número 44708 en la celda B2. Al usar la función texto con un formato de Fecha vemos que el resultado es una fecha 27/05/22.

= TEXTO(B2; “dd/mm/dd”)

En la tabla vemos diversos formatos.

Si usamos el formato “dd/mmm/dd”, en este caso en lugar del número del mes indicará las primeras 3 letras, en este caso sería: fecha 27/may/22.

= TEXTO(B2; “dd/mmm/dd”)

Puedes analizar todos los formatos.

Con horas.

El de las horas, Excel toma las 24 horas en un rango de 0 a 1. Cuando pasa de 1, cuenta 1 día y las horas se reinician a cero.

 Por eso 0.69377 es la hora 16:39:02 y 1.69377 es la misma hora 16:39:02, ya que solo cambiamos un día.

Y eso lo podemos ver en el último ejemplo de la tabla.

Formato de texto

Para más tutoriales de Excel ve a este enlace.

Algunos temas que te pueden interesar:

Concatenar en Excel (CONCATENATE en inglés).

Títulos en Excel (Estilos de texto)