Excel función SI (IF en inglés)

En este tutorial explicamos la función SI en Excel. Te decimos todos los parámetros que admite y mostramos algunos ejemplos de cómo se usa.

 

Resumen rápido Excel Formula SI (IF en inglés).

En este resumen rápido de Excel te decimos los parámetros de la función SI, más adelante dejamos un ejemplo.

Excel Función SI

¿Qué es la función Si en Excel?

La función Si de Excel es una condición, si se cumple la condición hacemos una cosa y si no se cumple hacemos otra.

Esta es la sintaxis:

= SI( Condición;  Si condición verdadera; Si condición falsa)

En inglés:

= IF( Condición;  Si condición verdadera; Si condición falsa)

Dónde:

  • Condición, es la condición con la que vamos a decidir qué hacer. Un ejemplo seria A1>=5.
  • Si condición verdadera, este será el resultado si la condición es verdadera. Puede ser un texto “Es mayor o igual que 5”. O bien podremos agregar alguna otra función aquí.
  • Si condición falsa, este será el resultado si la condición es Falsa. Al igual que la condición verdadera podemos poner un texto “Es menor que 5” o anidar alguna función.

Ejemplo.

En el resumen rápido ya describimos los parámetros de la función SI, ahora resolveremos dos ejemplos.

Función Si en Excel

Función SI simple.

Este es el ejemplo más simple para entender la formula SI o IF en inglés.

Tenemos un valor en la celda A3, queremos decir si es mayor o menor que 5. Así que usaremos esta función de la siguiente manera.

= SI(A3>=5; “Es mayor o igual que 5”; “Es menor que 5”)

La condición es si A3 es mayor o igual que 5.

  • Si en la celda A3 escribimos un 7, el 7 es mayor que 5 por lo que mostraremos el texto cuando la condición es verdadera: “Es mayor o igual que 5”.
  • Si en la celda A3 escribimos el número 2, es menor que el 5 por lo que la condición es Falsa, y ahora mostraremos el texto cuando no se cumple la condición: “Es menor que 5”.

Función SI anidada En Excel.

Podemos combinar dos o más funciones SI, para crear una lógica más compleja. Si dentro de una función SI agregamos otra, estamos anidando funciones SI. Y esto nos dará más opciones para tomas decisiones con esta función.

En el siguiente ejemplo, en la celda A5 tenemos un valor. Queremos indicar si el valor es Menor, Mayor o Igual al número 5.

Fórmula Si en Excel

= SI(A5>=5; SI(A5=5; “Igual”; “Mayor”); “Menor”)

Primero comparamos si A7 es mayor o igual que 5.

  • Si es verdadero, entonces comparamos si A7 es igual a 5.
    • Si es verdadero escribimos “Igual” como resultado.
    • Si es falso escribimos “Mayor”.
  • Si es falso, entonces escribimos “Menor”.

 

Otro ejemplo de la función SI anidada.

Ahora vamos a tener 2 funciones SI dentro de una. Veremos que tenemos 4 posibles resultados.

  • Si el valor de la celda A7 es mayor que 5 escribimos “Mayor”
  • Cuando sea igual a 5, escribimos “Igual”
  • En caso de ser menor que 5 pero mayor que 2 escribimos “Menor que 5 mayor a 2”
  • Si es menor que 2 escribimos “Menor a 2”

Si anidado Excel

En este caso tenemos lo siguiente:

= SI(A7>=5; SI(A7=5;”Igual”; “Mayor”); SI(A7>2;”Menor que 5 mayor a 2″;”Menor que 2″))

Si es verdadero entramos a una función SI que comprara si es igual o no que 5

En caso de ser falso entra a una función SI que compara si es mayor que dos o no y escribe el resultado.

Para más tutoriales de Excel ve a este enlace.

Algunos temas que te pueden interesar:

Función índice Excel

Concatenar en Excel (CONCATENATE en inglés).

 

 

Clave:

Excel funcion si, 10k-100k, baja, 3.07

Funcion si en Excel, 10k-100k, baja, 3.07

Si anidado Excel, 1k-10k, baja, 5

Funcion si Excel varias condiciones, 1k-10k, baja, 2.8

Formula condicional Excel, 1k-10k, baja, 0.75